• We have updated the site to the latest version. You will be required to log in to make sure your account is active. There are quite a few new functions so it will take a little time to get use to it. Please post if you see or have any issues.

06 RMK 700 loss of power at full throttle.

Muskyhunter22

New Member
Messages
2
Age
24
Location
Lodi Wi
Country
USA
Years Snowmobiling
3
Snowmobile
06 rmk700
I just purchased this sled with 2100 miles with a fresh lower rebuild. Starts up great and rides fine around 50mph. But when you give it full throttle it immediately bogs back down and gives a flashing check engine light. I'm pretty new on working on sleds. So trying to get some help on where to start.
 

850Switchback

Active Member
Messages
150
Age
45
Location
CT
Country
USA
Years Snowmobiling
30
Snowmobile
2020 Switchback XCR
I would start by looking in the owners manual to see what the flashing light means, I suspect it means the engine is detonating. You can get a electronic copy from Polaris at the link below if you don't have the original one.
With a fresh rebuild, its possible someone didn't torque the detonation sensor properly which makes them false read.
 

Muskyhunter22

New Member
Messages
2
Age
24
Location
Lodi Wi
Country
USA
Years Snowmobiling
3
Snowmobile
06 rmk700
I would start by looking in the owners manual to see what the flashing light means, I suspect it means the engine is detonating. You can get a electronic copy from Polaris at the link below if you don't have the original one.
With a fresh rebuild, its possible someone didn't torque the detonation sensor properly which makes them false read.
Thanks I will look into that!
 


Top Bottom