• We have updated the site to the latest version. You will be required to log in to make sure your account is active. There are quite a few new functions so it will take a little time to get use to it. Please post if you see or have any issues.

Tail Light 2010 IQ

lutzinmn

New Member
Messages
2
Age
60
Location
Minnesota
Country
USA
Years Snowmobiling
50
Snowmobile
2010 Polaris IQ
Starting out riding last night my tail light was working but my 12v accessory was not working. During riding my friend following me noticed my tail light starting flickering off and on and then went off for good. When the tail light went off my 12v accessory started working. My 12v accessory is connected directly to battery. I have no power going to tail light. I tested the bulb and the bulb is good. I am assuming there is/was a short somewhere. any ideas where to start looking? the wires at tail light before going through the tunnel look good. I do not know where the engine side of the tail light wire is located. I would appreciate any help.
 

MrSled

Administrator
Staff member
Admin
Messages
1,162
Location
Weston, WI
Country
USA
Years Snowmobiling
29
Snowmobile
SideWinder
Starting out riding last night my tail light was working but my 12v accessory was not working. During riding my friend following me noticed my tail light starting flickering off and on and then went off for good. When the tail light went off my 12v accessory started working. My 12v accessory is connected directly to battery. I have no power going to tail light. I tested the bulb and the bulb is good. I am assuming there is/was a short somewhere. any ideas where to start looking? the wires at tail light before going through the tunnel look good. I do not know where the engine side of the tail light wire is located. I would appreciate any help.

I would start at the seat and follow the wires back to the bars. You should be able to test for continuity on each wire.
 

lutzinmn

New Member
Messages
2
Age
60
Location
Minnesota
Country
USA
Years Snowmobiling
50
Snowmobile
2010 Polaris IQ
Thanks for your help. I found the issue. The plug end of wire from tail light was bad.
 


Top Bottom