• We have updated the site to the latest version. You will be required to log in to make sure your account is active. There are quite a few new functions so it will take a little time to get use to it. Please post if you see or have any issues.

2005 fusion 900 running very poor

clarenceb

New Member
Messages
3
Age
23
Location
mallorytown
Country
Canada
Years Snowmobiling
15
Snowmobile
2005 polaris fusion 900
okay so I traded for this sled and have had a lot of issues. have yet to ride it. im hoping someone can point me in the right direction. the oil pump cable was rotten and broke it left the pump to the full oil position. I replaced it and set it to factory spec. it then wouldn't idle and backfired so I checked the TPS setting and it was out to lunch so I followed the service manual to set it. but I powered up the ECM and back probed the sensor. after that was set it runs! but not well it doesn't idle very well still or at all and only revs up without the belt on. with the belt on it just bogs real bad and hardly moves. after running pulled plugs and found mag side to be fouled like its not firing. checked for spark. and both had great spark. replaced plugs with hotter plugs just to see what happens it runs and idles now but still bogs when trying to move and most of time it doesn't move. so would this be a injector problem could it be stuck on? it looks like its ground controlled so if its shorted to ground it would always be on. I'm unsure of what to do if anyone has any help it would be much appreciated.
 

clarenceb

New Member
Messages
3
Age
23
Location
mallorytown
Country
Canada
Years Snowmobiling
15
Snowmobile
2005 polaris fusion 900
I Should also note that both clutches are in working order. and no engine light
 

clarenceb

New Member
Messages
3
Age
23
Location
mallorytown
Country
Canada
Years Snowmobiling
15
Snowmobile
2005 polaris fusion 900
Thanks for a reply.
I did do a compression test and came out with 125psi for both sides
 

Hyper2000

New Member
Messages
13
Age
53
Location
Northern Ontario
Country
Canada
Years Snowmobiling
40
Snowmobile
His 2016 800 Switchback S
Her 2017 800 Switchback S
Son 2015 800 Rush
Daughter 2013 800 Pro R Adventure
Hi
Hoping you can help me out, my buddy has the same sled same problem were you able to resolve the issue
 

CFM

New Member
Messages
3
Age
52
Location
Dirt Floor in NH
Country
USA
Years Snowmobiling
50
Snowmobile
05 900 Fusion 12,500 miles
06 600HO M10 Fusion
Check fuel psi ?
Look inside tank fir deteriorating fuel pick up lines ?
Check for flywheel starting to separate and cut thru wires ?

Any other diagnostics performed ?
 


Top Bottom