1. We are no longer supporting TapaTalk as a mobile app for our sites. The TapaTalk App has many issues with speed on our server as well as security holes that leave us vulnerable to attacks and spammers.

2020 Indy 850

Discussion in 'Indy XC' started by Scott Mckibbon, Jan 26, 2020.

  1. Scott Mckibbon

    Scott Mckibbon New Member

    Messages:
    5
    Location:
    Miramichi New Brunswick
    Country:
    Canada
    Years Snowmobiling:
    50
    Snowmobile:
    2020 850 Indy 137
    I have a 2020 Indy 850 keeps getting a code DET cannot get it fixed is anyone else having this issue ?
    I guess the issues with this is at Hardcore Sledders
     
    Last edited: Jan 26, 2020
  2.  
  3. Mudgunner

    Mudgunner New Member

    Messages:
    16
    Location:
    Gagetown New Brunswick
    Country:
    Canada
    Years Snowmobiling:
    35
    Snowmobile:
    1992 Polaris Indy 440
    2003 Yamaha Venture 700
    2008 Polaris IQ 700
    2019 Polaris Indy XC 850 129”
    I’m not having that issue but it’s because of fuel quality. In your settings, set your fuel to a lower quality and the code will go away. If your set at 91 octane and the gas at the station isn’t 91 then you’ll get the code.
     
  4. Scott Mckibbon

    Scott Mckibbon New Member

    Messages:
    5
    Location:
    Miramichi New Brunswick
    Country:
    Canada
    Years Snowmobiling:
    50
    Snowmobile:
    2020 850 Indy 137
    Thanks for the reply and you are correct as Polaris is making a new program for computer suppose to reflash on Feb 15 as the 2020 Indy has been set up for USA Fuel 93 octane we only have 91 in Canada .
     
  5. Mike-DRH

    Mike-DRH New Member

    Messages:
    28
    Location:
    Hastings
    Country:
    USA
    Years Snowmobiling:
    40
    Snowmobile:
    2019 Polaris Rush 800
    I've never found 93 at any average stations in US.
     
  6. Scott Mckibbon

    Scott Mckibbon New Member

    Messages:
    5
    Location:
    Miramichi New Brunswick
    Country:
    Canada
    Years Snowmobiling:
    50
    Snowmobile:
    2020 850 Indy 137
    Oh really I am only going by what Polaris is telling me I hope it will fix the problem
     
  7. Bigfuse

    Bigfuse Moderator Staff Member Moderator

    Messages:
    608
    Location:
    Sunny Manitoba
    Country:
    Canada
    Years Snowmobiling:
    50+
    Snowmobile:
    2020 IndyXC 850
    Filled up at the Holiday gas station in Roseau yesterday and they only had 91 octane.
     
  8. 822

    822 New Member

    Messages:
    2
    Location:
    ontario
    Country:
    Canada
    Years Snowmobiling:
    30
    Snowmobile:
    2020 indy 850 xc
    talked with my dealer , they and Polaris not awre (or wont say ) anything about a new flash on the 2020 xc 850 ..byw hows your oil consumption ....horrible .??????/
     
  9. Scott Mckibbon

    Scott Mckibbon New Member

    Messages:
    5
    Location:
    Miramichi New Brunswick
    Country:
    Canada
    Years Snowmobiling:
    50
    Snowmobile:
    2020 850 Indy 137
    Well the flash is what my dealer told me they were waiting for on the 15th which is gone by and still no flash ,Oil consumption I think is ok but I would sure like to have the problem fixed so machine would run properly . Did not think I would have issues like that with new 850
     
  10. 822

    822 New Member

    Messages:
    2
    Location:
    ontario
    Country:
    Canada
    Years Snowmobiling:
    30
    Snowmobile:
    2020 indy 850 xc
    Me as well , My first Poo , rode and raced BRP for 15 years , never opened my hood , never changed plugs , never DET codes , sold my e tech with 5000 km original plugs , starts first time everytime no smoke good on fuel excellent on oil ... The Poo is a more fun ride but WTF Polaris BETTER fix this and stop the (were not aware off this ) BS

    Good luck to all 850 owners
     
  11. 2cyclemech

    2cyclemech New Member

    Messages:
    22
    Location:
    New Jersey
    Country:
    USA
    Years Snowmobiling:
    40
    Snowmobile:
    Polaris
    Same here 35yrs on doo no issues my 19 850 blew up yesterday in Quebec at 3200 rpm locked up solid sled has 3689 for mls not one indication it was gonna shit the bed an i had the 2020 flash which help with hanging idle an i was getting 200 mls to 2.5 qt of VES Extreme well season is over dropping sled at dealer cant trade will too much of hit due this eng BS
     
  12. Scott Mckibbon

    Scott Mckibbon New Member

    Messages:
    5
    Location:
    Miramichi New Brunswick
    Country:
    Canada
    Years Snowmobiling:
    50
    Snowmobile:
    2020 850 Indy 137
    Is there a lot of these engines blowing up? I had not heard of that I know my 2020 Indy does not work as it is suppose to since about 150 miles it ,it now has 2850 miles .I am not looking forward for that to happen . Warrenty on new sled does not seem to be much good if they can not fix it .
     
  13. 2cyclemech

    2cyclemech New Member

    Messages:
    22
    Location:
    New Jersey
    Country:
    USA
    Years Snowmobiling:
    40
    Snowmobile:
    Polaris
    i dont know about 2020 850 but the 19 have a different oil check valve an silcone issue causing line to pop off i was getting a det code an switched to the E10 mode an it went away also i got a det code when the temps outside were in the upper 30 when temp dropped into the 20 no codes in e10 or non eth mode check out HCS forum to get more info on 850 issues also i am still running original belt with no issues just a little dust nothing major my sled get to dealer later this week since they r 5 hrs away
     
  14. 2cyclemech

    2cyclemech New Member

    Messages:
    22
    Location:
    New Jersey
    Country:
    USA
    Years Snowmobiling:
    40
    Snowmobile:
    Polaris
     
  15. 2cyclemech

    2cyclemech New Member

    Messages:
    22
    Location:
    New Jersey
    Country:
    USA
    Years Snowmobiling:
    40
    Snowmobile:
    Polaris
    Dealer reported that ring locating pin moved slid in ring spun on pto side when hooked it took out cyl , head power valve dealer said that they were going to rebuild it instead of replacing question did 2020 piston have a update i see that part number is changed from 2019 adding to story eng never overheated was running at 125 when eng blew sled cant be picked up til lock down is over
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.