1. We are no longer supporting TapaTalk as a mobile app for our sites. The TapaTalk App has many issues with speed on our server as well as security holes that leave us vulnerable to attacks and spammers.

Dead sled

Discussion in 'Mountain' started by Peeler, Nov 18, 2016.

  1. Peeler

    Peeler New Member

    Messages:
    2
    Location:
    Lakeview, Oregon
    Country:
    USA
    Years Snowmobiling:
    20 plus
    Snowmobile:
    2009 Polaris 800 RMK
    Last season sled sputtered ,gauges flickered, then sled died.
    Was told it was vr, replaced it, sputtered a lot then ecu fried.
    Now I have replaced the capacitor, vr, ecu, still won't start.
    No spark at plugs. Have stator on order. Any ideas on what else
    it could be? Looking for any ideas.
    Thanks
    Danny
     
  2.  
  3. Lid1

    Lid1 Active Member

    Messages:
    156
    Location:
    Ny
    Country:
    USA
    Years Snowmobiling:
    32
    Snowmobile:
    Axys
    Was the correct capacitor replaced. ? There are more than one.
     
  4. Lid1

    Lid1 Active Member

    Messages:
    156
    Location:
    Ny
    Country:
    USA
    Years Snowmobiling:
    32
    Snowmobile:
    Axys
    Did you test output from stator ?
     
  5. Dave64

    Dave64 New Member

    Messages:
    16
    Location:
    Anoka, MN
    Country:
    USA
    Years Snowmobiling:
    42
    Snowmobile:
    11 SBA 800, 05 XC700, 99 500 Classic, 95 XLT
    How is your ground?
     
  6. Brock

    Brock Well-Known Member

    Messages:
    2,141
    Location:
    Ontario
    Country:
    Canada
    Years Snowmobiling:
    30+
    Snowmobile:
    Polaris
    What's the model and year of sled ?
     
  7. OutCast

    OutCast Active Member

    Messages:
    295
    Location:
    Cape Breton
    Could be the main relay. Try testing the stator before you spend that amount of cash to replace it just thinking its that. The main relay is like $20 or a little more.
     
  8. Peeler

    Peeler New Member

    Messages:
    2
    Location:
    Lakeview, Oregon
    Country:
    USA
    Years Snowmobiling:
    20 plus
    Snowmobile:
    2009 Polaris 800 RMK
    Sled is a 09 Polaris 800 RMK. Less than 2k miles. Capacitor was ordered from local Polaris shop, so hope it was the right one.
    have not checked stator out put or grounds yet. weather and work are not cooperating.
    Thanks for all the help, really appreciate it.
    Keep the ideas coming. Will post what I find wrong with it.
    Danny
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.