1. We are no longer supporting TapaTalk as a mobile app for our sites. The TapaTalk App has many issues with speed on our server as well as security holes that leave us vulnerable to attacks and spammers.

Exhaust Valve Removal

Discussion in 'Rush/Switchback' started by Wilmotriverside, Jan 9, 2020.

  1. Wilmotriverside

    Wilmotriverside New Member

    Messages:
    19
    Location:
    Twin lakes wi
    I removed my exhaust valves for cleaning and one stays in the assembly and the other one falls out. Seems like its not connected to the cable. Is it broken? If it is how is it connected to the cable? Will I need to have the valves relearned?
     
  2.  
  3. Rbell14

    Rbell14 New Member

    Messages:
    14
    Location:
    Plymouth, Mi
    Country:
    USA
    Years Snowmobiling:
    10
    Snowmobile:
    2015 Yamaha Viper RTX SE
    Interested in this process. Unsure exactly how you clean these. Hope to learn from guys on this forum.
     
  4. Turtle

    Turtle New Member

    Messages:
    14
    Location:
    Marathon, WI
    Country:
    USA
    Years Snowmobiling:
    30
    Snowmobile:
    2017 Polaris Switchback 800 Pro S LE
    2015 Yamaha SR Viper RTX MPI turbo
    2007 Yamaha FX Phazer GT
    The exhaust valve is a two piece unit. Part of it is bolted to a bar connecting the valves together. The cable pulls on the bar. The other part of the valve is held in with springs.
     
  5. Pro116

    Pro116 Moderator Staff Member Moderator

    Messages:
    260
    Location:
    Shiocton,WI
    One is probably just gunned up more then the other I have had that happen many times. There should be no cables it pressurized/ spring activated. Yamaha and cats use a cable.
     
  6. Turtle

    Turtle New Member

    Messages:
    14
    Location:
    Marathon, WI
    Country:
    USA
    Years Snowmobiling:
    30
    Snowmobile:
    2017 Polaris Switchback 800 Pro S LE
    2015 Yamaha SR Viper RTX MPI turbo
    2007 Yamaha FX Phazer GT
    800 engine is cable operated. 600 engine is pressure operated.
     
  7. Pro116

    Pro116 Moderator Staff Member Moderator

    Messages:
    260
    Location:
    Shiocton,WI

    Sorry thought this was the proride forum didn’t see axys. I just clicked on recent post and not on specific forum.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.