1. We are no longer supporting TapaTalk as a mobile app for our sites. The TapaTalk App has many issues with speed on our server as well as security holes that leave us vulnerable to attacks and spammers.

Xc 850 possible electrical problem

Discussion in 'Indy XC' started by Mudgunner, Feb 9, 2020.

  1. Mudgunner

    Mudgunner New Member

    Messages:
    16
    Location:
    Gagetown New Brunswick
    Country:
    Canada
    Years Snowmobiling:
    35
    Snowmobile:
    1992 Polaris Indy 440
    2003 Yamaha Venture 700
    2008 Polaris IQ 700
    2019 Polaris Indy XC 850 129”
    Was out for a few hours riding last night, near the end of my trip, my 850 Indy stalled while I was driving about 30 mph. It may be a coincidence but it stalled right after I turned off my hand warmers. I started it up again, drove a few feet and it died again. This time all the lights went out before the engine stalled. Turned the key and it just clicked, I tried again and it started no problem. Drove about 100 ft and it died again with lights out before stalling. The engine light came on while it was stalling but wasn’t on again after starting again. It started right up and I drove the rest of trip home without problems, about 30 kms. I have lots of warranty but would like to know if anyone has had this issue and what happened.
     
  2.  

  3. Bigfuse

    Bigfuse Moderator Staff Member Moderator

    Messages:
    618
    Location:
    Sunny Manitoba
    Country:
    Canada
    Years Snowmobiling:
    50+
    Snowmobile:
    2020 IndyXC 850
    Nope. Never had that problem.
     
  4. Cory McArthur

    Cory McArthur New Member

    Messages:
    3
    Location:
    Winnipeg
    Country:
    Canada
    Years Snowmobiling:
    35
    Snowmobile:
    Polaris Indy XC 137 850
    I only have about 450 miles on mine so far, but haven't had that issue.
     
  5. Mudgunner

    Mudgunner New Member

    Messages:
    16
    Location:
    Gagetown New Brunswick
    Country:
    Canada
    Years Snowmobiling:
    35
    Snowmobile:
    1992 Polaris Indy 440
    2003 Yamaha Venture 700
    2008 Polaris IQ 700
    2019 Polaris Indy XC 850 129”
    No sure exactly what was wrong but the PTO side was too rich fouling the spark plug. I had to replace it a few times and I’m way past the breakin period. The dealer put a new flash in it which is supposed to correct the plug fouling.
     
  6. MJT

    MJT New Member

    Messages:
    3
    Location:
    wi
    i have a 2020 indy 850 xcr, mine will just fall on its face and the engine light comes on while at any postion in the throttle and then just comes back to life, the only 2 ways to get the code is to leave the engine running and press the middle button for about 5 seconds and it will tell you the code, if you shut the key off it will go away, unless you hook up a digital wrench... my code is a 651 witch is the mag side injector has a issue with being shorted out or something to that affect... had mine at the shop the first time and polaris told them to bend the pins in the ecu on booth connectors... got it back and it did the same thing after 30mi so its back at the dealer!!! fun cause i just have time to run this thing back and forth while they figure it out
     
  7. Mudgunner

    Mudgunner New Member

    Messages:
    16
    Location:
    Gagetown New Brunswick
    Country:
    Canada
    Years Snowmobiling:
    35
    Snowmobile:
    1992 Polaris Indy 440
    2003 Yamaha Venture 700
    2008 Polaris IQ 700
    2019 Polaris Indy XC 850 129”
    I’ve put some miles on since the new flash and the fouling issue is gone, plus the engine sounds way better now.
     
    Rcrgelting likes this.
  8. racer487

    racer487 New Member

    Messages:
    12
    Location:
    16143
    Country:
    USA
    Years Snowmobiling:
    15
    Snowmobile:
    2013 polaris pro r switchback 800
    [QUOTE="Mudgunner, post: 16963, member: 2591" Hi i am having the same issue on my 2013 switchback 800 recently. At around every 60 miles or so it fouls out the left side. . I have switched from left to right the coils, fuel injectors , checked spark strength with a gap tester with it almost all the way open & it has great spark. Not sure where to go from here. You have given me hope since it seemed to cure your problem. how many mile have you put on it since? I am going to call the dealer to check for updates. Thanks
     
  9. Mudgunner

    Mudgunner New Member

    Messages:
    16
    Location:
    Gagetown New Brunswick
    Country:
    Canada
    Years Snowmobiling:
    35
    Snowmobile:
    1992 Polaris Indy 440
    2003 Yamaha Venture 700
    2008 Polaris IQ 700
    2019 Polaris Indy XC 850 129”
    I’ve gone around 500 miles since and no issues. I just pulled the plugs the other day to check them and they’re both chocolate brown, perfect mixture.
     

Share This Page



  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.